import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[.\\]\n";
final String string = "[2] O. Y. Abramov, “Industry Best Practices And The Role Of TRIZ In Developing New Products,” in ResearchGate, 2013.\n"
+ "[3] D. Cavallucci, S. Fuhlhaber, and A. Riwan, “Assisting Decisions in Inventive Design of Complex Engineering Systems,” Procedia Eng., vol. 131, pp. 975–983, 2015.\n"
+ "[4] W. Yan, H. Liu, C. Zanni-Merk, and D. Cavallucci, “IngeniousTRIZ: An automatic ontology-based system for solving inventive problems,” Knowl.-Based Syst., vol. 75, pp. 52–65, Feb. 2015.\n"
+ "[5] B.Campbell,“Brainstorming and TRIZ,” TRIZ J., 2003. February,http://www.triz journal.com/archives/2003/02/index.htm. \n"
+ "[6] A. Aamodt and E. Plaza, “Case-based reasoning: Foundational issues, methodological variations, and system approaches,” AI Commun., vol. 7, no. 1, pp. 39–59, 1994.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}