import Foundation
let pattern = #"(-|\s*|\/\/|\/\*|<!--|\*|[*[0-9.]*)(\s*)(TAG|d])(-*|:*|\s*)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ###"""
// TAG: this is bug!
// TAG: this is bug!
\t // TAG: this is bug!
<!-- TAG: this is a hack!
<!-- TAG: this is a hack!
* TAG: need to fix this - TAG
- TAG: this is a todo!
/* TAG: this is a todo!
// TAG: warning or ignore
- [ ] this is an unfinished item
- [x] this item is finished
- [/] this item is finished
TAG: I said something
my comment - TAG
TAG attention!
?? question?
## Sample
[1.2d] | E2E QA & Debugging
[0.6d] | Release
~~ 14.9d
~~ 19d
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)