# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(-|\s*|\/\/|\/\*|<!--|\*|[*[0-9.]*)(\s*)(TAG|d])(-*|:*|\s*)(.*)"
test_str = ("// TAG: this is bug!\n"
" // TAG: this is bug!\n"
"\\t // TAG: this is bug!\n"
"<!-- TAG: this is a hack!\n"
" <!-- TAG: this is a hack!\n"
"* TAG: need to fix this - TAG\n"
"- TAG: this is a todo!\n"
"/* TAG: this is a todo!\n"
"// TAG: warning or ignore\n"
"- [ ] this is an unfinished item\n"
"- [x] this item is finished\n"
"- [/] this item is finished\n"
"TAG: I said something\n"
"my comment - TAG\n\n"
"TAG attention!\n"
"?? question?\n"
"## Sample\n"
"[1.2d] | E2E QA & Debugging\n"
"[0.6d] | Release\n"
"~~ 14.9d\n"
"~~ 19d\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.