$re = '/^[a-z0-9_-]{3,16}$/m';
$str = 'not-valid user
valid-user
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);