const regex = /^[a-z0-9_-]{3,16}$/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z0-9_-]{3,16}$', 'm')
const str = `not-valid user
valid-user
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}