re = /(?<=\\)[^\\]+(?=]$)/
str = '[HKEY_LOCAL_MACHINE\\SOFTWARE\\foo\\bar\\key path]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end