$re = '/(?<=\\\\)[^\\\\]+(?=]$)/';
$str = '[HKEY_LOCAL_MACHINE\\SOFTWARE\\foo\\bar\\key path]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);