const regex = /time=+([0-9]*.[0-9]{2})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('time=+([0-9]*.[0-9]{2})', '')
const str = `28 bytes from 173.194.116.216: icmp_seq=5 ttl=57 time=22.882 ms`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}