using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"time=+([0-9]*.[0-9]{2})";
string input = @"28 bytes from 173.194.116.216: icmp_seq=5 ttl=57 time=22.882 ms";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}