// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^<a[^>]*href="([^"]+)"[^>]*([^<]+).*$"#).unwrap();
let string = "<a href=\"final/main.html\">Multimedia Implementation</a><br/>
<a href=\"final/toc.html\">Table of Contents</a><br/>
<a href=\"final/pref01.html\">About the Author</a><br/>
<a href=\"final/pref02.html\">About the Technical Reviewers</a><br/>
<a href=\"final/pref03.html\">Acknowledgments</a><br/>
<a href=\"final/part01.html\">Part I: Introduction and Overview</a><br/>
<a href=\"final/ch01.html\">Chapter 1. Technical Overview</a><br/>";
let substitution = "<navpoint id=\"n\" playOrder=\"\">\\n<navLabel><text>$2</text></navLabel>\\n<content src=\"$1\" />\\n</navpoint>\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}