#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^<a[^>]*href="([^"]+)"[^>]*([^<]+).*$"
Local $sString = "<a href="final/main.html">Multimedia Implementation</a><br/>" & @CRLF & _
"<a href="final/toc.html">Table of Contents</a><br/>" & @CRLF & _
"<a href="final/pref01.html">About the Author</a><br/>" & @CRLF & _
"<a href="final/pref02.html">About the Technical Reviewers</a><br/>" & @CRLF & _
"<a href="final/pref03.html">Acknowledgments</a><br/>" & @CRLF & _
"<a href="final/part01.html">Part I: Introduction and Overview</a><br/>" & @CRLF & _
"<a href="final/ch01.html">Chapter 1. Technical Overview</a><br/>"
Local $sSubst = "<navpoint id="n" playOrder="">\n<navLabel><text>$2</text></navLabel>\n<content src="$1" />\n</navpoint>\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)