use strict;
my $str = 'asdas asdasdas dasdas das d/asd asdaasd #˝˝¥ʼ¯ˍ˙œß¯';
my $regex = qr/^[\p{L}\p{M}\p{N}\p{P}\p{C}\p{Z}\p{S}][^=@]+$/up;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}