package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[\p{L}\p{M}\p{N}\p{P}\p{C}\p{Z}\p{S}][^=@]+$`)
var str = `asdas asdasdas dasdas das d/asd asdaasd #˝˝¥ʼ¯ˍ˙œß¯`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}