re = /(^(1?)(\s?)([\s]?)((\(\d{3}\))|(\d{3}))([\s]?)([\s-]?)(\d{3})([\s-]?)(\d{4})+$)/mi
str = '555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
1 555 555 5555
800-692-7753
6505552368
-1 (757) 622-7382
555)-555-5555
(555-555-5555
1 (555) 555-5555
8oo-six427676;laskdjf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end