const regex = /(^(1?)(\s?)([\s]?)((\(\d{3}\))|(\d{3}))([\s]?)([\s-]?)(\d{3})([\s-]?)(\d{4})+$)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^(1?)(\\s?)([\\s]?)((\\(\\d{3}\\))|(\\d{3}))([\\s]?)([\\s-]?)(\\d{3})([\\s-]?)(\\d{4})+$)', 'gmi')
const str = `555-555-5555
(555)555-5555
(555) 555-5555
555 555 5555
1 555 555 5555
800-692-7753
6505552368
-1 (757) 622-7382
555)-555-5555
(555-555-5555
1 (555) 555-5555
8oo-six427676;laskdjf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}