re = /^.*IMAP Error: Login failed for .* from (?P<host>.*)\. AUTHENTICATE PLAIN: Authentication failed\. in .* \(POST .*\)$/m
str = '[16-Sep-2016 17:48:15 +0200]: <r24n59kn> IMAP Error: Login failed for ssdfsdf from 213.97.11.31. AUTHENTICATE PLAIN: Authentication failed. in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 197 (POST /?_task=login?_task=login&_action=login)
[16-Sep-2016 17:48:28 +0200]: <r24n59kn> IMAP Error: Login failed for ssdfsdf from 213.97.11.31. AUTHENTICATE PLAIN: Authentication failed. in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 197 (POST /?_task=login?_task=login&_action=login)
[16-Sep-2016 17:48:47 +0200]: <r24n59kn> IMAP Error: Login failed for sdfgsdfgsdfg from 213.97.11.31. AUTHENTICATE PLAIN: Authentication failed. in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 197 (POST /?_task=login?_task=login&_action=login)
[16-Sep-2016 17:49:12 +0200]: <r24n59kn> IMAP Error: Login failed for sdfgsdfgsdfg from 213.97.11.31. AUTHENTICATE PLAIN: Authentication failed. in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 197 (POST /?_task=login?_task=login&_action=login)
[16-Sep-2016 17:49:39 +0200]: <r24n59kn> IMAP Error: Login failed for sdfgsdfgsdfg from 213.97.11.31. AUTHENTICATE PLAIN: Authentication failed. in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 197 (POST /?_task=login?_task=login&_action=login)
[16-Sep-2016 17:50:23 +0200]: <r24n59kn> IMAP Error: Login failed for sdfgsdfgsdfg from 213.97.11.31. AUTHENTICATE PLAIN: Authentication failed. in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 197 (POST /?_task=login?_task=login&_action=login)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end