import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*IMAP Error: Login failed for .* from (?P<host>.*)\\. AUTHENTICATE PLAIN: Authentication failed\\. in .* \\(POST .*\\)$";
final String string = "[16-Sep-2016 17:48:15 +0200]: <r24n59kn> IMAP Error: Login failed for ssdfsdf from 213.97.11.31. AUTHENTICATE PLAIN: Authentication failed. in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 197 (POST /?_task=login?_task=login&_action=login)\n"
+ "[16-Sep-2016 17:48:28 +0200]: <r24n59kn> IMAP Error: Login failed for ssdfsdf from 213.97.11.31. AUTHENTICATE PLAIN: Authentication failed. in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 197 (POST /?_task=login?_task=login&_action=login)\n"
+ "[16-Sep-2016 17:48:47 +0200]: <r24n59kn> IMAP Error: Login failed for sdfgsdfgsdfg from 213.97.11.31. AUTHENTICATE PLAIN: Authentication failed. in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 197 (POST /?_task=login?_task=login&_action=login)\n"
+ "[16-Sep-2016 17:49:12 +0200]: <r24n59kn> IMAP Error: Login failed for sdfgsdfgsdfg from 213.97.11.31. AUTHENTICATE PLAIN: Authentication failed. in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 197 (POST /?_task=login?_task=login&_action=login)\n"
+ "[16-Sep-2016 17:49:39 +0200]: <r24n59kn> IMAP Error: Login failed for sdfgsdfgsdfg from 213.97.11.31. AUTHENTICATE PLAIN: Authentication failed. in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 197 (POST /?_task=login?_task=login&_action=login)\n"
+ "[16-Sep-2016 17:50:23 +0200]: <r24n59kn> IMAP Error: Login failed for sdfgsdfgsdfg from 213.97.11.31. AUTHENTICATE PLAIN: Authentication failed. in /usr/share/roundcube/program/lib/Roundcube/rcube_imap.php on line 197 (POST /?_task=login?_task=login&_action=login)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}