const regex = /#\[\[(?<name>.+?)\]\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#\\[\\[(?<name>.+?)\\]\\]', 'g')
const str = `my first name is #[[1:hashTag:Rameez]] and second name is #[[2:hashTag:Rameez2]].
Did I forget to mention that my name is #[[3:hashTag:Rameez3]]?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}