using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#\[\[(?<name>.+?)\]\]";
string input = @"my first name is #[[1:hashTag:Rameez]] and second name is #[[2:hashTag:Rameez2]].
Did I forget to mention that my name is #[[3:hashTag:Rameez3]]?";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}