re = /^([a-z]+\:)\/*([^\/\s\?]*)(\?[a-z0-9\-@\^=%&;\/~\+]*)*[\?]?([^ \#]*)#?([^ \#]*)/i
str = 'http:///evil-phisher/foo.html#h\\\\a\\\\s\\\\h'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end