import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-z]+\\:)\\/*([^\\/\\s\\?]*)(\\?[a-z0-9\\-@\\^=%&;\\/~\\+]*)*[\\?]?([^ \\#]*)#?([^ \\#]*)";
final String string = "http:///evil-phisher/foo.html#h\\\\a\\\\s\\\\h";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}