$re = '/((?:(?:https?|ftp)+(?:\:\/\/))?)+(?:(?:(?:www(?:(?:[\d]{1})?)\.|[a-z0-9-_]{1,}))+\.(?:com|me|ru|net|biz|info|fm|su|ua|to|us|[a-z]{1,5}))+(?:(?:[a-z0-9\/\?=-_.&]{1,})?)/ism';
$str = 'Дорого времени суток, составил регулярку для парсинга ссылок вида http://example.com/ http://www.example.com/, www.example.com, example.com, example.com?act=1 и тд и тп, вот регулярка:';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);