import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:(?:https?|ftp)+(?:\\:\\/\\/))?)+(?:(?:(?:www(?:(?:[\\d]{1})?)\\.|[a-z0-9-_]{1,}))+\\.(?:com|me|ru|net|biz|info|fm|su|ua|to|us|[a-z]{1,5}))+(?:(?:[a-z0-9\\/\\?=-_.&]{1,})?)";
final String string = "Дорого времени суток, составил регулярку для парсинга ссылок вида http://example.com/ http://www.example.com/, www.example.com, example.com, example.com?act=1 и тд и тп, вот регулярка:";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}