$re = '/site\.com\/(?!fr)/';
$str = 'site.com/fr/bla
site.com/bla';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);