using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"site\.com\/(?!fr)";
string input = @"site.com/fr/bla
site.com/bla";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}