re = /^[^0-9a-zA-z.\s!"#$%&'()*+,\-.\/:;<=>?
@[\]\^_
`{|}~。「」、・ヲァィゥェォャュョッーアイウエオカキクケコサシスセソ
タチツテトナニヌネノハヒフヘホマミムメモヤユヨラリルレロワン゙゚]+$/
str = 'わたしは今日は!'
# Print the match result
str.match(re) do |match|
puts match.to_s
end