package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^0-9a-zA-z.\s!"#$%&'()*+,\-./:;<=>?
@[\]\^_
`{|}~。「」、・ヲァィゥェォャュョッーアイウエオカキクケコサシスセソ
タチツテトナニヌネノハヒフヘホマミムメモヤユヨラリルレロワン゙゚]+$`)
var str = `わたしは今日は!`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}