# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(FLOWLINKMEDIA ID=)"
test_str = ("<FLOWLINKMEDIA ID=\"LDP_COMPLETE\">\n"
" <PART NAME=\"MAIN\">\n"
" <GRPH ZORDER=\"0\" W=\"4000\" H=\"3000\">\n"
" <SOURCE>back01.png</SOURCE>\n"
" </GRPH>\n"
" <GRPH ZORDER=\"1\" TP=\"#00FF00\">\n"
" <SOURCE LOCATION=\"VAR\">MKTAD:MAIN_TILE</SOURCE>\n"
" </GRPH>\n"
" </PART>\n"
" <PART NAME=\"OMP\">\n"
" <REGION NAME=\"REQUEST_BOTTOM\">\n"
" <TEXTBOX STYLE=\"REQUEST_PROMPT\">\n"
" <SOURCE LOCATION=\"VAR\">LANG:INF_ONEMOMENT</SOURCE>\n"
" </TEXTBOX>\n"
" </REGION>\n"
" </PART>\n"
" </FLOWLINKMEDIA>\n\n"
" <FLOWLINKMEDIA ID=\"LDP_DEPOSITMENU\">\n"
" <SM NAME=\"SMDL\" />\n"
" <PART NAME=\"MAIN\">\n"
" <GRPH ZORDER=\"0\" W=\"4000\" H=\"3000\">\n"
" <SOURCE>back01.png</SOURCE>\n"
" </GRPH>\n"
" <REGION NAME=\"MARKETING_BANNER\">\n"
" <GRPH ZORDER=\"1\" TP=\"#00FF00\">\n"
" <SOURCE LOCATION=\"VAR\">MKTAD:OPENER_TILE</SOURCE>\n"
" </GRPH>\n"
" </REGION>\n"
" <REGION NAME=\"MAIN\">\n"
" <TEXTBOX STYLE=\"LINE1_LARGEPROMPT_WIDE\">\n"
" <SOURCE LOCATION=\"VAR\">LANG:PRM_INT_LDPMENU</SOURCE>\n"
" </TEXTBOX>\n"
" <SPEECH SCR_COMP=\"PROMPT\">\n"
" <SOURCE LOCATION=\"VAR\">LANG:TTS_PAUSE</SOURCE>\n"
" </SPEECH>\n"
" <TEXTBOX STYLE=\"PROMPT_SUBTEXT\">\n"
" <VARSOURCE>\n"
" <SOURCE LOCATION=\"VAR\">LANG:INF_BCREFERENCE</SOURCE>\n"
" <VAR NAME=\"BCTOACCT\">\n"
" <SOURCE LOCATION=\"VAR\">BUSOBJ:USERDATA\\TOACCT\\NAME_NUMBER</SOURCE>\n"
" </VAR>\n"
" </VARSOURCE>\n"
" </TEXTBOX>\n"
" <SPEECH SCR_COMP=\"PROMPT\">\n"
" <SOURCE LOCATION=\"VAR\">LANG:TTS_PAUSE</SOURCE>\n"
" </SPEECH>\n"
" </REGION>\n"
" </PART>\n"
" <PART NAME=\"NAV_BAR\">\n"
" <REGION NAME=\"NAVIGATION_BAR\">\n"
" <GRPH ZORDER=\"1\" TP=\"#00FF00\">\n"
" <SOURCE>nav_bar.png</SOURCE>\n"
" </GRPH>\n"
" </REGION>\n"
" </PART>\n"
" <PART NAME=\"CANCEL\">\n"
" <ACTIONKEY VALUE=\"CANCEL\"/>\n"
" <REGION NAME=\"NAVIGATION_BAR_LEFT_BTN\" TOUCH=\"Y\">\n"
" <GRPH ZORDER=\"2\" Y=\"80\" X=\"90\">\n"
" <SOURCE>nav_exit.png</SOURCE>\n"
" </GRPH>\n"
" <TEXTBOX STYLE=\"NAVBAR_LEFT_OPTION\">\n"
" <SOURCE LOCATION=\"VAR\">LANG:FDK_CANCEL</SOURCE>\n"
" </TEXTBOX>\n"
" </REGION>\n"
" </PART>\n"
" <PART NAME=\"TYPE_PANEL\">\n"
" <REGION NAME=\"MAIN_PANEL\" TOUCH=\"N\">\n"
" <GRPH ZORDER=\"1\">\n"
" <SOURCE>main_panel.png</SOURCE>\n"
" </GRPH>\n"
" </REGION>\n"
" </PART>\n"
" <DISPLAYLIST LISTNAME=\"DEPTYPE\" EVENTNAME=\"FE_SELECTED\">\n"
" <POSITIONS>\n"
" <POS REGION_NAME=\"MAIN_PANEL_1OF3\" TOUCH=\"Y\">\n"
" <SPITEM ITEMNAME=\"SHOW\" ENABLEINPUT=\"Y\">\n"
" <GRPH ZORDER=\"3\">\n"
" <SOURCE>primary_tile_1.png</SOURCE>\n"
" </GRPH>\n"
" <TEXTBOX STYLE=\"PRIMARY_TILE1_CENTER\">\n"
" <VARSOURCE LOCATION=\"VAR\">\n"
" <SOURCE>LANG:INF_LDPMENU_</SOURCE>\n"
" <SOURCE LOCATION=\"DISPLAYLIST\">VALUE</SOURCE>\n"
" </VARSOURCE>\n"
" </TEXTBOX>\n"
" </SPITEM>\n"
" <SPITEM ITEMNAME=\"GHOST\" ENABLEINPUT=\"N\">\n"
" <GRPH ZORDER=\"1\" TP=\"#00FF00\">\n"
" <SOURCE>primary_tile_1_ghost.png</SOURCE>\n"
" </GRPH>\n"
" <TEXTBOX STYLE=\"PRIMARY_TILE1_CENTER_1OF2\">\n"
" <VARSOURCE LOCATION=\"VAR\">\n"
" <SOURCE>LANG:INF_LDPMENU_</SOURCE>\n"
" <SOURCE LOCATION=\"DISPLAYLIST\">VALUE</SOURCE>\n"
" </VARSOURCE>\n"
" </TEXTBOX>\n"
" <TEXTBOX STYLE=\"PRIMARY_TILE1_CENTER_2OF2\">\n"
" <SOURCE LOCATION=\"VAR\">LANG:MENU_TEMP_UNAVAILABLE</SOURCE>\n"
" </TEXTBOX>\n"
" </SPITEM>\n"
" <SPITEM ITEMNAME=\"HIDE\" ENABLEINPUT=\"N\"/>\n"
" <RESPONSE DISPLAYTIME=\"100\">\n"
" <GRPH ZORDER=\"0\" TP=\"#00FF00\">\n"
" <SOURCE>Highlight\\primary_tile_1.png</SOURCE>\n"
" </GRPH>\n"
" </RESPONSE>\n"
" </POS>\n"
" <POS REGION_NAME=\"MAIN_PANEL_2OF3\" TOUCH=\"Y\">\n"
" <SPITEM ITEMNAME=\"SHOW\" ENABLEINPUT=\"Y\">\n"
" <GRPH ZORDER=\"3\">\n"
" <SOURCE>primary_tile_1.png</SOURCE>\n"
" </GRPH>\n"
" <TEXTBOX STYLE=\"PRIMARY_TILE1_CENTER\">\n"
" <VARSOURCE LOCATION=\"VAR\">\n"
" <SOURCE>LANG:INF_LDPMENU_</SOURCE>\n"
" <SOURCE LOCATION=\"DISPLAYLIST\">VALUE</SOURCE>\n"
" </VARSOURCE>\n"
" </TEXTBOX>\n"
" </SPITEM>\n"
" <SPITEM ITEMNAME=\"GHOST\" ENABLEINPUT=\"N\">\n"
" <GRPH ZORDER=\"1\" TP=\"#00FF00\">\n"
" <SOURCE>primary_tile_1_ghost.png</SOURCE>\n"
" </GRPH>\n"
" <TEXTBOX STYLE=\"PRIMARY_TILE1_CENTER_1OF2\">\n"
" <VARSOURCE LOCATION=\"VAR\">\n"
" <SOURCE>LANG:INF_LDPMENU_</SOURCE>\n"
" <SOURCE LOCATION=\"DISPLAYLIST\">VALUE</SOURCE>\n"
" </VARSOURCE>\n"
" </TEXTBOX>\n"
" <TEXTBOX STYLE=\"PRIMARY_TILE1_CENTER_2OF2\">\n"
" <SOURCE LOCATION=\"VAR\">LANG:MENU_TEMP_UNAVAILABLE</SOURCE>\n"
" </TEXTBOX>\n"
" </SPITEM>\n"
" <SPITEM ITEMNAME=\"HIDE\" ENABLEINPUT=\"N\"/>\n"
" <RESPONSE DISPLAYTIME=\"100\">\n"
" <GRPH ZORDER=\"0\" TP=\"#00FF00\">\n"
" <SOURCE>Highlight\\primary_tile_1.png</SOURCE>\n"
" </GRPH>\n"
" </RESPONSE>\n"
" </POS>\n"
" <POS REGION_NAME=\"MAIN_PANEL_3OF3\" TOUCH=\"Y\">\n"
" <SPITEM ITEMNAME=\"SHOW\" ENABLEINPUT=\"Y\">\n"
" <GRPH ZORDER=\"3\">\n"
" <SOURCE>primary_tile_1.png</SOURCE>\n"
" </GRPH>\n"
" <TEXTBOX STYLE=\"PRIMARY_TILE1_CENTER\">\n"
" <VARSOURCE LOCATION=\"VAR\">\n"
" <SOURCE>LANG:INF_LDPMENU_</SOURCE>\n"
" <SOURCE LOCATION=\"DISPLAYLIST\">VALUE</SOURCE>\n"
" </VARSOURCE>\n"
" </TEXTBOX>\n"
" </SPITEM>\n"
" <SPITEM ITEMNAME=\"GHOST\" ENABLEINPUT=\"N\">\n"
" <GRPH ZORDER=\"1\" TP=\"#00FF00\">\n"
" <SOURCE>primary_tile_1_ghost.png</SOURCE>\n"
" </GRPH>\n"
" <TEXTBOX STYLE=\"PRIMARY_TILE1_CENTER_1OF2\">\n"
" <VARSOURCE LOCATION=\"VAR\">\n"
" <SOURCE>LANG:INF_LDPMENU_</SOURCE>\n"
" <SOURCE LOCATION=\"DISPLAYLIST\">VALUE</SOURCE>\n"
" </VARSOURCE>\n"
" </TEXTBOX>\n"
" <TEXTBOX STYLE=\"PRIMARY_TILE1_CENTER_2OF2\">\n"
" <SOURCE LOCATION=\"VAR\">LANG:MENU_TEMP_UNAVAILABLE</SOURCE>\n"
" </TEXTBOX>\n"
" </SPITEM>\n"
" <SPITEM ITEMNAME=\"HIDE\" ENABLEINPUT=\"N\"/>\n"
" <RESPONSE DISPLAYTIME=\"100\">\n"
" <GRPH ZORDER=\"0\" TP=\"#00FF00\">\n"
" <SOURCE>Highlight\\primary_tile_1.png</SOURCE>\n"
" </GRPH>\n"
" </RESPONSE>\n"
" </POS>\n"
" </POSITIONS>\n"
" <SMDEFINED>\n"
" <SMITEM SMNAME=\"MORE\" EVENTNAME=\"MORE\">\n"
" <GRPH ZORDER=\"1\" TP=\"#00FF00\">\n"
" <SOURCE>primary_tile_1.png</SOURCE>\n"
" </GRPH>\n"
" <TEXTBOX STYLE=\"PRIMARY_TILE1_CENTER\">\n"
" <SOURCE LOCATION=\"VAR\">LANG:FDK_MOREACCTS</SOURCE>\n"
" </TEXTBOX>\n"
" </SMITEM>\n"
" </SMDEFINED>\n"
" </DISPLAYLIST>\n"
" </FLOWLINKMEDIA>")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.