#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b(FLOWLINKMEDIA ID=)"
Local $sString = "<FLOWLINKMEDIA ID="LDP_COMPLETE">" & @CRLF & _
" <PART NAME="MAIN">" & @CRLF & _
" <GRPH ZORDER="0" W="4000" H="3000">" & @CRLF & _
" <SOURCE>back01.png</SOURCE>" & @CRLF & _
" </GRPH>" & @CRLF & _
" <GRPH ZORDER="1" TP="#00FF00">" & @CRLF & _
" <SOURCE LOCATION="VAR">MKTAD:MAIN_TILE</SOURCE>" & @CRLF & _
" </GRPH>" & @CRLF & _
" </PART>" & @CRLF & _
" <PART NAME="OMP">" & @CRLF & _
" <REGION NAME="REQUEST_BOTTOM">" & @CRLF & _
" <TEXTBOX STYLE="REQUEST_PROMPT">" & @CRLF & _
" <SOURCE LOCATION="VAR">LANG:INF_ONEMOMENT</SOURCE>" & @CRLF & _
" </TEXTBOX>" & @CRLF & _
" </REGION>" & @CRLF & _
" </PART>" & @CRLF & _
" </FLOWLINKMEDIA>" & @CRLF & _
"" & @CRLF & _
" <FLOWLINKMEDIA ID="LDP_DEPOSITMENU">" & @CRLF & _
" <SM NAME="SMDL" />" & @CRLF & _
" <PART NAME="MAIN">" & @CRLF & _
" <GRPH ZORDER="0" W="4000" H="3000">" & @CRLF & _
" <SOURCE>back01.png</SOURCE>" & @CRLF & _
" </GRPH>" & @CRLF & _
" <REGION NAME="MARKETING_BANNER">" & @CRLF & _
" <GRPH ZORDER="1" TP="#00FF00">" & @CRLF & _
" <SOURCE LOCATION="VAR">MKTAD:OPENER_TILE</SOURCE>" & @CRLF & _
" </GRPH>" & @CRLF & _
" </REGION>" & @CRLF & _
" <REGION NAME="MAIN">" & @CRLF & _
" <TEXTBOX STYLE="LINE1_LARGEPROMPT_WIDE">" & @CRLF & _
" <SOURCE LOCATION="VAR">LANG:PRM_INT_LDPMENU</SOURCE>" & @CRLF & _
" </TEXTBOX>" & @CRLF & _
" <SPEECH SCR_COMP="PROMPT">" & @CRLF & _
" <SOURCE LOCATION="VAR">LANG:TTS_PAUSE</SOURCE>" & @CRLF & _
" </SPEECH>" & @CRLF & _
" <TEXTBOX STYLE="PROMPT_SUBTEXT">" & @CRLF & _
" <VARSOURCE>" & @CRLF & _
" <SOURCE LOCATION="VAR">LANG:INF_BCREFERENCE</SOURCE>" & @CRLF & _
" <VAR NAME="BCTOACCT">" & @CRLF & _
" <SOURCE LOCATION="VAR">BUSOBJ:USERDATA\TOACCT\NAME_NUMBER</SOURCE>" & @CRLF & _
" </VAR>" & @CRLF & _
" </VARSOURCE>" & @CRLF & _
" </TEXTBOX>" & @CRLF & _
" <SPEECH SCR_COMP="PROMPT">" & @CRLF & _
" <SOURCE LOCATION="VAR">LANG:TTS_PAUSE</SOURCE>" & @CRLF & _
" </SPEECH>" & @CRLF & _
" </REGION>" & @CRLF & _
" </PART>" & @CRLF & _
" <PART NAME="NAV_BAR">" & @CRLF & _
" <REGION NAME="NAVIGATION_BAR">" & @CRLF & _
" <GRPH ZORDER="1" TP="#00FF00">" & @CRLF & _
" <SOURCE>nav_bar.png</SOURCE>" & @CRLF & _
" </GRPH>" & @CRLF & _
" </REGION>" & @CRLF & _
" </PART>" & @CRLF & _
" <PART NAME="CANCEL">" & @CRLF & _
" <ACTIONKEY VALUE="CANCEL"/>" & @CRLF & _
" <REGION NAME="NAVIGATION_BAR_LEFT_BTN" TOUCH="Y">" & @CRLF & _
" <GRPH ZORDER="2" Y="80" X="90">" & @CRLF & _
" <SOURCE>nav_exit.png</SOURCE>" & @CRLF & _
" </GRPH>" & @CRLF & _
" <TEXTBOX STYLE="NAVBAR_LEFT_OPTION">" & @CRLF & _
" <SOURCE LOCATION="VAR">LANG:FDK_CANCEL</SOURCE>" & @CRLF & _
" </TEXTBOX>" & @CRLF & _
" </REGION>" & @CRLF & _
" </PART>" & @CRLF & _
" <PART NAME="TYPE_PANEL">" & @CRLF & _
" <REGION NAME="MAIN_PANEL" TOUCH="N">" & @CRLF & _
" <GRPH ZORDER="1">" & @CRLF & _
" <SOURCE>main_panel.png</SOURCE>" & @CRLF & _
" </GRPH>" & @CRLF & _
" </REGION>" & @CRLF & _
" </PART>" & @CRLF & _
" <DISPLAYLIST LISTNAME="DEPTYPE" EVENTNAME="FE_SELECTED">" & @CRLF & _
" <POSITIONS>" & @CRLF & _
" <POS REGION_NAME="MAIN_PANEL_1OF3" TOUCH="Y">" & @CRLF & _
" <SPITEM ITEMNAME="SHOW" ENABLEINPUT="Y">" & @CRLF & _
" <GRPH ZORDER="3">" & @CRLF & _
" <SOURCE>primary_tile_1.png</SOURCE>" & @CRLF & _
" </GRPH>" & @CRLF & _
" <TEXTBOX STYLE="PRIMARY_TILE1_CENTER">" & @CRLF & _
" <VARSOURCE LOCATION="VAR">" & @CRLF & _
" <SOURCE>LANG:INF_LDPMENU_</SOURCE>" & @CRLF & _
" <SOURCE LOCATION="DISPLAYLIST">VALUE</SOURCE>" & @CRLF & _
" </VARSOURCE>" & @CRLF & _
" </TEXTBOX>" & @CRLF & _
" </SPITEM>" & @CRLF & _
" <SPITEM ITEMNAME="GHOST" ENABLEINPUT="N">" & @CRLF & _
" <GRPH ZORDER="1" TP="#00FF00">" & @CRLF & _
" <SOURCE>primary_tile_1_ghost.png</SOURCE>" & @CRLF & _
" </GRPH>" & @CRLF & _
" <TEXTBOX STYLE="PRIMARY_TILE1_CENTER_1OF2">" & @CRLF & _
" <VARSOURCE LOCATION="VAR">" & @CRLF & _
" <SOURCE>LANG:INF_LDPMENU_</SOURCE>" & @CRLF & _
" <SOURCE LOCATION="DISPLAYLIST">VALUE</SOURCE>" & @CRLF & _
" </VARSOURCE>" & @CRLF & _
" </TEXTBOX>" & @CRLF & _
" <TEXTBOX STYLE="PRIMARY_TILE1_CENTER_2OF2">" & @CRLF & _
" <SOURCE LOCATION="VAR">LANG:MENU_TEMP_UNAVAILABLE</SOURCE>" & @CRLF & _
" </TEXTBOX>" & @CRLF & _
" </SPITEM>" & @CRLF & _
" <SPITEM ITEMNAME="HIDE" ENABLEINPUT="N"/>" & @CRLF & _
" <RESPONSE DISPLAYTIME="100">" & @CRLF & _
" <GRPH ZORDER="0" TP="#00FF00">" & @CRLF & _
" <SOURCE>Highlight\primary_tile_1.png</SOURCE>" & @CRLF & _
" </GRPH>" & @CRLF & _
" </RESPONSE>" & @CRLF & _
" </POS>" & @CRLF & _
" <POS REGION_NAME="MAIN_PANEL_2OF3" TOUCH="Y">" & @CRLF & _
" <SPITEM ITEMNAME="SHOW" ENABLEINPUT="Y">" & @CRLF & _
" <GRPH ZORDER="3">" & @CRLF & _
" <SOURCE>primary_tile_1.png</SOURCE>" & @CRLF & _
" </GRPH>" & @CRLF & _
" <TEXTBOX STYLE="PRIMARY_TILE1_CENTER">" & @CRLF & _
" <VARSOURCE LOCATION="VAR">" & @CRLF & _
" <SOURCE>LANG:INF_LDPMENU_</SOURCE>" & @CRLF & _
" <SOURCE LOCATION="DISPLAYLIST">VALUE</SOURCE>" & @CRLF & _
" </VARSOURCE>" & @CRLF & _
" </TEXTBOX>" & @CRLF & _
" </SPITEM>" & @CRLF & _
" <SPITEM ITEMNAME="GHOST" ENABLEINPUT="N">" & @CRLF & _
" <GRPH ZORDER="1" TP="#00FF00">" & @CRLF & _
" <SOURCE>primary_tile_1_ghost.png</SOURCE>" & @CRLF & _
" </GRPH>" & @CRLF & _
" <TEXTBOX STYLE="PRIMARY_TILE1_CENTER_1OF2">" & @CRLF & _
" <VARSOURCE LOCATION="VAR">" & @CRLF & _
" <SOURCE>LANG:INF_LDPMENU_</SOURCE>" & @CRLF & _
" <SOURCE LOCATION="DISPLAYLIST">VALUE</SOURCE>" & @CRLF & _
" </VARSOURCE>" & @CRLF & _
" </TEXTBOX>" & @CRLF & _
" <TEXTBOX STYLE="PRIMARY_TILE1_CENTER_2OF2">" & @CRLF & _
" <SOURCE LOCATION="VAR">LANG:MENU_TEMP_UNAVAILABLE</SOURCE>" & @CRLF & _
" </TEXTBOX>" & @CRLF & _
" </SPITEM>" & @CRLF & _
" <SPITEM ITEMNAME="HIDE" ENABLEINPUT="N"/>" & @CRLF & _
" <RESPONSE DISPLAYTIME="100">" & @CRLF & _
" <GRPH ZORDER="0" TP="#00FF00">" & @CRLF & _
" <SOURCE>Highlight\primary_tile_1.png</SOURCE>" & @CRLF & _
" </GRPH>" & @CRLF & _
" </RESPONSE>" & @CRLF & _
" </POS>" & @CRLF & _
" <POS REGION_NAME="MAIN_PANEL_3OF3" TOUCH="Y">" & @CRLF & _
" <SPITEM ITEMNAME="SHOW" ENABLEINPUT="Y">" & @CRLF & _
" <GRPH ZORDER="3">" & @CRLF & _
" <SOURCE>primary_tile_1.png</SOURCE>" & @CRLF & _
" </GRPH>" & @CRLF & _
" <TEXTBOX STYLE="PRIMARY_TILE1_CENTER">" & @CRLF & _
" <VARSOURCE LOCATION="VAR">" & @CRLF & _
" <SOURCE>LANG:INF_LDPMENU_</SOURCE>" & @CRLF & _
" <SOURCE LOCATION="DISPLAYLIST">VALUE</SOURCE>" & @CRLF & _
" </VARSOURCE>" & @CRLF & _
" </TEXTBOX>" & @CRLF & _
" </SPITEM>" & @CRLF & _
" <SPITEM ITEMNAME="GHOST" ENABLEINPUT="N">" & @CRLF & _
" <GRPH ZORDER="1" TP="#00FF00">" & @CRLF & _
" <SOURCE>primary_tile_1_ghost.png</SOURCE>" & @CRLF & _
" </GRPH>" & @CRLF & _
" <TEXTBOX STYLE="PRIMARY_TILE1_CENTER_1OF2">" & @CRLF & _
" <VARSOURCE LOCATION="VAR">" & @CRLF & _
" <SOURCE>LANG:INF_LDPMENU_</SOURCE>" & @CRLF & _
" <SOURCE LOCATION="DISPLAYLIST">VALUE</SOURCE>" & @CRLF & _
" </VARSOURCE>" & @CRLF & _
" </TEXTBOX>" & @CRLF & _
" <TEXTBOX STYLE="PRIMARY_TILE1_CENTER_2OF2">" & @CRLF & _
" <SOURCE LOCATION="VAR">LANG:MENU_TEMP_UNAVAILABLE</SOURCE>" & @CRLF & _
" </TEXTBOX>" & @CRLF & _
" </SPITEM>" & @CRLF & _
" <SPITEM ITEMNAME="HIDE" ENABLEINPUT="N"/>" & @CRLF & _
" <RESPONSE DISPLAYTIME="100">" & @CRLF & _
" <GRPH ZORDER="0" TP="#00FF00">" & @CRLF & _
" <SOURCE>Highlight\primary_tile_1.png</SOURCE>" & @CRLF & _
" </GRPH>" & @CRLF & _
" </RESPONSE>" & @CRLF & _
" </POS>" & @CRLF & _
" </POSITIONS>" & @CRLF & _
" <SMDEFINED>" & @CRLF & _
" <SMITEM SMNAME="MORE" EVENTNAME="MORE">" & @CRLF & _
" <GRPH ZORDER="1" TP="#00FF00">" & @CRLF & _
" <SOURCE>primary_tile_1.png</SOURCE>" & @CRLF & _
" </GRPH>" & @CRLF & _
" <TEXTBOX STYLE="PRIMARY_TILE1_CENTER">" & @CRLF & _
" <SOURCE LOCATION="VAR">LANG:FDK_MOREACCTS</SOURCE>" & @CRLF & _
" </TEXTBOX>" & @CRLF & _
" </SMITEM>" & @CRLF & _
" </SMDEFINED>" & @CRLF & _
" </DISPLAYLIST>" & @CRLF & _
" </FLOWLINKMEDIA>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")