# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:https?:\/\/)?(?:www.)?instagram.com\/?([a-zA-Z0-9\.\_\-]+)?\/([p]+)?([reel]+)?([tv]+)?([stories]+)?\/([a-zA-Z0-9\-\_\.]+)\/?([0-9]+)?"
test_str = ("// Group 2\n"
"https://www.instagram.com/p/CKYJRXVnwMO/?utm_source=ig_web_copy_link\n"
"instagram.com/p/CKYJRXVnwMO\n"
"www.instagram.com/p/CKYJRXVnwMO\n"
"https://www.instagram.com/taiga765/p/CYS-O2Gr8xZ/?utm_medium=copy_link\n"
"https://www.instagram.com/y.uuno/p/CXR5ATPls5M/?utm_medium=copy_link\n"
"// Group 3\n"
"http://www.instagram.com/reel/CRftq6QgG89/?utm_source=ig_web_copy_link\n"
"instagram.com/reel/CRftq6QgG89/\n"
"www.instagram.com/reel/CRftq6QgG89/\n"
"https://www.instagram.com/reel/CXR2xvbgCKW/?utm_medium=copy_link\n"
"// Group 4\n"
"https://www.instagram.com/tv/CN4RZWGn5wS/?utm_source=ig_web_copy_link\n"
"instagram.com/tv/CN4RZWGn5wS/\n"
"www.instagram.com/tv/CN4RZWGn5wS/\n"
"// Group 5\n"
"https://www.instagram.com/stories/sintha_tatha/2725190842360050880/\n"
"https://www.instagram.com/stories/urkawaiibae/2725982322342818754/\n"
"https://www.instagram.com/stories/willypangestu_/2725773180739197900/\n"
"https://www.instagram.com/stories/atrisna477769/\n\n"
"https://www.instagram.com/stories/highlights/17910460144693951/\n"
"www.instagram.com/stories/highlights/17879710684406193/\n"
"instagram.com/stories/highlights/17879710684406193/")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.