const regex = new RegExp('(\\w*)(\\d(?:\\/\\d)*)(?:\\.)?(\\d*)?$', 'gm')
const str = `GigabitEthernet0/0/0
GigabitEthernet0/0
FastEthernet0
Gi0/0/0
F0
GigabitEthernet0/0/0.23
Gi0/0.1
F0.101
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}