package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w*)(\d(?:\/\d)*)(?:\.)?(\d*)?$`)
var str = `GigabitEthernet0/0/0
GigabitEthernet0/0
FastEthernet0
Gi0/0/0
F0
GigabitEthernet0/0/0.23
Gi0/0.1
F0.101
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}