// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)".+?""#).unwrap();
let string = "<\"dd1242__dd\">
<book navtitle=\"CHAPTER_7_GIFT_POLICY\" href=\"../contents/CHAPTER_7_GIFT_POLICY.htm\" format=\"html\" processing-role=\"normal\">
ljkasdf";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}