re = /".+?"/
str = '<"dd1242__dd">
<book navtitle="CHAPTER_7_GIFT_POLICY" href="../contents/CHAPTER_7_GIFT_POLICY.htm" format="html" processing-role="normal">
ljkasdf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end