re = /^(BSR_+[0-9]{4}(0[1-9]|1[0-2])(0[1-9]|[1-2][0-9]|3[0-1])[T](2[0-3]|[01][0-9])[0-5][0-9][0-5][0-9])+(.csv)$/m
str = 'BSR_20190228T030404.csv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end