package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(BSR_+[0-9]{4}(0[1-9]|1[0-2])(0[1-9]|[1-2][0-9]|3[0-1])[T](2[0-3]|[01][0-9])[0-5][0-9][0-5][0-9])+(.csv)$`)
var str = `BSR_20190228T030404.csv`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}