$re = '/^-?\d{0,}(\,\d{1,})?$/m';
$str = '1,234
2,5
888888888,1
88888
1
2
FOO
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);