#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?\d{0,}(\,\d{1,})?$"
Local $sString = "1,234" & @CRLF & _
"2,5" & @CRLF & _
"888888888,1" & @CRLF & _
"88888" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"2" & @CRLF & _
"FOO" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")