re = /(?:^|(?<=>))([\s\S]*?)(?:(?=<)|$)/m
str = '<p>sentence 1</p><p>sentence 2</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end