$re = '/(?:^|(?<=>))([\s\S]*?)(?:(?=<)|$)/m';
$str = '<p>sentence 1</p><p>sentence 2</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);