$re = '/W(indows|INDOWS)9?[58]/m';
$str = 'windows95
windows98
Windows98
WINDOWS95
windowsXP
windows2000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);