package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)W(indows|INDOWS)9?[58]`)
var str = `windows95
windows98
Windows98
WINDOWS95
windowsXP
windows2000
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}