$re = '/^([1]\-[A-Z]{3}\-\d{3})|([A-Z]{3}\-\d{3})$/m';
$str = '1-AAA-123
AAA-000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);