package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1]\-[A-Z]{3}\-\d{3})|([A-Z]{3}\-\d{3})$`)
var str = `1-AAA-123
AAA-000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}