$re = '/[a-zA-Z]+@\w+\.com/m';
$str = 'CoreyMSchafer@gmail.com
corey.schafer@university.edu
corey-321-schafer@my-work.net
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);