package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z]+@\w+\.com`)
var str = `CoreyMSchafer@gmail.com
corey.schafer@university.edu
corey-321-schafer@my-work.net
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}