$re = '/(?:^|^)\s*(?:export\s+)?([\w.-]+)(?:\s*=\s*?|:\s+?)(\s*\'(?:\\\\\'|[^\'])*\'|\s*\"(?:\\\\\"|[^\"])*\"|\s*`(?:\\\\`|[^`])*`|[^#\r\n]+)?\s*(?:#.*)?(?:$|$)/m';
$str = 'FOO=BAR
FOOISH = BARISH
export ZEBRA=ELEPHANT
FOO=bar none
JUNK=an experiment #ends here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);