package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^|^)\s*(?:export\s+)?([\w.-]+)(?:\s*=\s*?|:\s+?)(\s*'(?:\\'|[^'])*'|\s*\"(?:\\\"|[^\"])*\"|\s*`(?:\\`|[^`])*`|[^#\r\n]+)?\s*(?:#.*)?(?:$|$)`)
var str = `FOO=BAR
FOOISH = BARISH
export ZEBRA=ELEPHANT
FOO=bar none
JUNK=an experiment #ends here`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}