$re = '/^(r|d)\.edtd\.eset\.com$/mi';
$str = 'r.edtd.eset.com
d.edtd.eset.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);