package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(r|d)\.edtd\.eset\.com$`)
var str = `r.edtd.eset.com
d.edtd.eset.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}